
These Release Notes outline the new features and changes in eClass Grades® 
version 6.9.3 for Windows, including changes and new features from version 6.9.2 
to 6.9.3. These Release Notes also provide instructions for installing eClass Grades 
version 6.9.3.

You can install eClass Grades onto a server or a computer using the installer that 
you download from the Chancery Support web site. You can also copy the installer 
onto a CD to install on computers. Diskette installers are no longer available.

Getting Training
Chancery offers training courses to help you get every advantage from your Student 
Management Solution™. We are committed to helping you put our solutions to 
work. Our broad training options are designed with you in mind so that you’ll 
receive the most suitable and effective training for your needs.

Choose from onsite training, regional workshops, live online training, or Chancery 
University. We can also create a customized training program to meet your school’s 
needs.

Call us toll free at 1-800-999-9931 and ask for Training, or click Training on our 
Support web site at http://support.chancery.com for an up-to-date list of scheduled 
courses.

Compatibility
eClass Grades 6.9.3 is not compatible with Windows 3.1 or Windows 95.

eClass Grades 6.9.3 must be installed on every computer that uses it. You cannot 
launch eClass Grades 6.9.3 over the network or from a different computer than the 
one you are working at. If you have been launching your present version of 
eClass Grades over a network, you will not be able to do so. You can, however, save 
files on network disk drives.

eClass Grades 6.9.3 can read files created by older versions of eClass Grades. 
However, older versions of eClass Grades will not be able to read files created by 
eClass Grades version 6.9.3.

eClass Grades version 6.9.3 is fully cross-platform compatible. You can start 
working on your Class files on a Windows PC, and then move the files over to a 
Mac (latest version is 6.9.1) and continue working on your files. For more 
information about cross-platform compatibility, see your eClass Grades User Guide 
or refer to the online Help.
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eClass Grades 6.9.3 Windows Release Notes
Additional Information
The User Guide is also available in PDF format, which you can download from our 
Support web site at http://support.chancery.com. To order copies of the User Guide, 
call Chancery Customer Service at 1-800-999-9931.

Make sure you meet all hardware and software requirements before installing 
eClass Grades. To get the latest updates, or to check hardware and software 
requirements, visit our Support web site at http://support.chancery.com.

What’s New in This Version

What’s Fixed or Changed in This Version

Autofill Alternate Grades eClass Grades can automatically transfer rounded grades for grading periods to the 
Alternate Grades Percent column.
This enhancement affects only districts using alternate grades, which are grades that are 
used in place of the actual calculated grades. Alternate grades are useful when you want 
Overall Summaries to reflect the total of values that are rounded to the nearest whole 
number instead of values rounded to the nearest tenth.
By default, Overall Summaries in eClass Grades reflect the totals of values rounded to 
the nearest tenth. This creates a discrepancy if you compare the Overall Summaries to 
external summaries that reflect the total of values rounded to the nearest whole number. 
For example, an Overall Summary of 12.5 and 12.5 is 26 when the values are rounded to 
the nearest whole number (13 + 13) but is 25 when the values are rounded to the 
nearest tenth.
To resolve the discrepancy, some districts enable alternate grades and manually enter the 
rounded version of some or all grading period values into the Alternate Percent column. 
For information about enabling alternate grades, see “Overriding Grades” in the online 
Help or the eClass Grades User Guide.
Version 6.9.3 frees you from having to manually enter the rounded version of grading 
period values into the Alternate Percent column. Instead, eClass Grades can autofill the 
Alternate Grades Percent column with rounded versions of the calculated grades for 
some or all grading periods where alternate grades are enabled.
To enable autofilling of alternate grades:
1. On the Edit menu, click Preferences.
2. In the Preferences dialog, click the dropdown menu and choose Autofill Alternate 
Grades.
3. Under Autofill Alternate Grades For, click either Single Grading Period with 
Alternate Grades Enabled or All Grading Periods with Alternate Grades Enabled, and 
then click OK.
The Autofill Alternate Grades command on the File menu is enabled.
To autofill alternate grades:
1. If you are autofilling alternate grades in a single grading period, open the Scores 
window to that grading period.
2. On the File menu, click Autofill Alternate Grades.

Warning message for 
Chancery SMS Class 
Conversion

When you choose Convert Chancery SMS Class Files from the File menu more than 
once, you are now prompted with a warning message if any class files already exist.
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Known Problems and Work-Arounds

Folder where class files saved 
during Chancery SMS Class 
Conversion

When you use Convert Chancery SMS Class Files on the File menu, the class files are 
also placed in locations specified for Default Folders Class Backups 1 through 5.
This is corrected. Now, when you use Convert Chancery SMS Class Files on the File 
menu, class files are placed only in the same locations as the Chancery SMS roster files.

Changes to the Program 
Folder are ignored

During installation, a shortcut to eClass Grades was placed in the Chancery SMS folder 
of the Start menu, even if you specified a different location in the Program Folders box 
on the Select Program Folder dialog.
This is corrected. The shortcut is placed in the folder you specify on the Select Program 
Folder dialog.

Virus scanning software 
interferes with exports

If you are running virus scanning software, when you export, the exported file may have 
no data.
To work around this issue, disable the virus scanning software before the export. 
Alternatively, make a copy of the export and edit the default filename so that it must be 
manually entered each time the filter is run.

Importing email addresses 
more than once causes a 
General Protection Fault

If you import email addresses more than once, the addresses are not updated, and a 
General Protection Fault (GPF) may occur the next time you select Student Email 
Addresses from the Class menu. After a GPF, you must reboot your computer.
To update email addresses and prevent this error:
Update email addresses manually, rather than importing them.
OR
Delete all the existing email addresses and then import new ones.
To resolve this error after it occurs:
1. Add a nonexistent student to the class by opening the Students window, moving to 
the blank row just below the last student in the list, and typing the nonexistent student’s 
name.
2. With the new student selected, from the Class menu, click Student Email Addresses. 
3. In the Student Email Addresses dialog, select an existing student, change the student’s 
email address, and click OK. The error is resolved.
4. Clean up by changing the existing student’s email address back to its original version, 
and making the new, nonexistent student inactive by adding a “~” symbol to the 
beginning of the student’s name.

Grading Period grades are 
calculated differently for 
bonus assignments

When using Ignore Category Weights for the Grading Period calculation, if an 
assignment for 0 possible Points (meaning it is for bonus marks) is the only assignment 
in a given category in the Assignments window, the Grade column in the Scores window 
may be inaccurate.
This issue does not occur if the Grading Period contains another non-zero assignment 
in the same category.

Unexpected values for class 
averages on reports

If the overall summary includes active students with all excused scores, the Overall 
Summaries Class Averages on Reports may show a negative, unexpected value.
To work around this issue, mark the students with all excused scores as inactive, run the 
report, then make the students active again.
OR
Do not include class averages on reports.
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Selecting fields for Group 
report

If you select one or more of Citizenship, Work Habit, or Pass/Fail in the Student Data 
dialog from the Style menu, these fields might cause assignment fields to be cut off in 
the Group report.
If you select these fields, print the Group report once without selecting any assignments. 
Then deselect these fields in the Student Data dialog, and print the Group report again 
to show assignments.

Import using Scantron filter Scantron filters are not supported in this release. We are working with Scantron to 
resolve this in a future release.

Using Netscape to view 
online Help

If both Internet Explorer and Netscape are installed on your computer, pressing F1 
always uses Internet Explorer to view online Help.
Use Internet Explorer to view online Help; or if you want to use Netscape, uninstall 
Internet Explorer.

Entering alternate grade 
percentages

The Alternate Grades Percent column in the Scores window is independent of the 
Rounding Options in the Grades dialog from the Style menu. If you select “Grade 
Description and Percentages” as your rounding option, the Grade column in the Scores 
window rounds the percentages to whole numbers, for example, 80% A. However, the 
Alternate Grades Percent column is independent of your selected rounding option, and 
shows the number of decimal places you enter, without rounding the number.
When entering alternate grade percentages, enter a maximum of one decimal place, so 
that calculations based on alternate percentages remain consistent. For example, enter 
70.5 and not 70.35.

Entering alternate grade 
percentages for a Category

This applies only if you enter alternate grades for categories, and select “Ignore category 
weights” in the When Calculating Grade dropdown menu in the Grading Periods dialog.
When you enter an alternate grade percentage for a Category, the points scored for the 
Grading Period that includes that Category might not be correct on reports. The points 
scored totals for grading periods and overall summaries would not have the points 
scored from the category in which the alternate grade percentage was entered. The 
Grading Period percentage is correct regardless.
If you select Allow Alternate Grade for a Category, de-select Points in the Grading 
Period Summaries column in the Grades dialog from the Style menu.

Alternate Grades letter grade 
description for grading 
periods when exporting

When using Export Term Marks from the File menu, the letter grade descriptions for 
Alternate Grades might not be correct. This happens when either the Alternate Percent 
or Alternate Description is empty, but not when both are empty.
If <blank> or a valid alternate grade percentage is entered for a grading period, then 
always enter a valid alternate grade letter grade description. Do not leave the letter grade 
description column empty.

Entering more than three 
email addresses for students

In the Student Email Addresses dialog from the Class menu, if you enter more than 
three email addresses for a student, only the first two, and last email address receives a 
report.
Do not use more than three email addresses per student.

Using Win School to write 
setup.gbk and roster files

If you’re using Win School to write setup.gbk and roster files and then use a Macintosh 
to create the generic class files, all the comments in the class file might become 
duplicated. For the comments to become duplicated, you’d have to: 
1) use Win School to write setup.gbk or roster files
2) use eClass Grades for Macintosh to create a generic class file with comments
3) use eClass Grades for Windows to import that roster
As a work-around, create the generic class file using eClass Grades for Windows.

Opening version 6.8.x class 
files that have password 
protection

The first time you use version 6.9.3 to open a version 6.8.x class file that is password 
protected, you are asked for the password twice. After you open and save the file in 
version 6.9.3, the problem doesn’t occur again.
When opening a version 6.9.3 class file that is password protected, you are asked for the 
password once.
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Downloading and Installing eClass Grades

Before You Begin
• Back up your data. Make sure you have at least two sets of current backups.

• Have your Win School Registration and Installation sheet at hand.

• Quit all applications and temporarily disable any virus checking software.

Downloading eClass Grades
1 At your web browser, go to http://support.chancery.com, and log on to the 

Chancery Support web site.

2 Navigate to the Download section of the Support web site.

3 Locate and download eClass Grades 6.9.3 for Windows.

If necessary, use a third-party tool such as WinZip® to decompress the files. For 
instructions on using WinZip, see KBase item 9075, “Utilities for expanding 
compressed files” on the Chancery Support web site.

Note

When decompressing the files, make sure you extract the Installer onto a server with 
access permissions set to read/write. If you run the Installer directly from WinZip you 
will be prompted to enter your Registration Key information even if you have an existing 
version of eClass Grades or Win School installed.

Installing eClass Grades
1 If you are using version 6.8.x of eClass Grades, rename the folder containing 

the earlier version and append the word “old” to the folder name.

2 If you are using Windows XP, Windows 2000, or Windows NT, log on with 
administrator access so as not to get error messages during installation.

3 Navigate to the files that you downloaded and decompressed, double-click 
Setup.exe, and follow the onscreen instructions.

Saving class files on a Novell 
server

If you are using Windows 98 on a Novell network, files with names longer than 8 
characters and extensions longer than 3 characters are saved in 8.3 format.
If you are using Windows 98 on a Novell network, use Save Class As from the File 
menu to save your files with long file names.

Showing classes in the Open 
Class dialog

If a class name contains a period (.), that class is not displayed by default in the Open 
Class dialog from the File menu. For example, Spanish 9 (1).cls would be displayed but 
Spanish Lit. 9(1).cls would not, because “Spanish Lit. 9(1).cls” has a period in the class 
name.
To display all classes:
In the File name text box of the Open Class dialog, change “*.cls” to “*.*”.
OR
Remove extra periods in the folder that contain the classes.
OR
In Win School Details, make sure the Course Name does not contain periods.
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Note

If you want to install eClass Grades so that it appears in the Win School Shell, install 
eClass Grades into the Win School Modules folder. 

4 If you have version 6.9.x installed, running the installer uninstalls the old 
version first. This is by design. Run the installer again to install the new version.

Installing eClass Grades from a Server
This is the easier method of installing eClass Grades. Copy the eClass Grades 
installer onto a server, then at each workstation, install eClass Grades using the 
installer on the server.

AT THE SERVER:

1 If you are using version 6.8.x, rename the folder containing version 6.8.x of 
eClass Grades and append the word “old” to the folder name. 

2 Put all the files that you downloaded and decompressed into one folder.

3 Make sure the access permission on the installer files are set to read/write.

AT EACH WORKSTATION:

1 If you are using version 6.8.x, rename the folder containing version 6.8.x of 
eClass Grades and append the word “old” to the folder name. 

2 Log on using a username with administrator access, and locate and open the 
folder containing the eClass Grades installer files on the server.

Note

If you want to install eClass Grades so that it appears in the Win School Shell, install 
eClass Grades into the Win School Modules folder. 

3 Double-click Setup.exe and follow the onscreen instructions.

4 When you see the ‘Let teachers change “Allow Administrator Access” option 
for their class files’ option during installation:

• To allow teachers to change the Allow Administrator Access option for their 
class file, leave the option selected. Later, when you choose Set Password 
from the Class menu, the Allow Administrator Access option is available.

• To prevent teachers from changing the Allow Administrator Access option 
for their class file, deselect the option. Later, when you choose Set Password 
from the Class menu, the Allow Administrator Access option is dimmed and 
cannot be changed.

This option applies to all teachers’ classes, and can only be changed by 
reinstalling eClass Grades.

If your school has a security policy regarding whether teachers can change the 
Allow Administrator Access option, make sure you follow it.

5 Follow the onscreen instructions to complete the installation.
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If a message displays indicating you have the latest version of Windows 
common controls, click OK, then click Restart Now. After your computer has 
restarted, the installation is complete and you can start to use eClass Grades.

© 2003 Chancery Software Ltd.
Mac School, Win School, eClass, and their logos are registered trademarks of Chancery Software Ltd.
Chancery SMS and Chancery Student Management Solutions are trademarks of Chancery Software Ltd.
All other trademarks are property of their respective owners.
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